Anyone having issues accessing the forums
11-14-2014, 03:04 AM, (This post was last modified: 11-14-2014, 03:05 AM by Bring4th_Steve.)
#86
RE: Anyone having issues accessing the forums
Thanks for your patience today, everyone. Yes, there was a significant outage on November 13th as I worked with the web host to improve the performance of a few components on Bring4th, while also dealing with some system and data failures along the way.

For those who are interested in the technical recap, we:

1. Changed to a faster PHP version (DSO version enabled)
2. Added APC (Alternative PHP Caching) to reduce processor load and page render times by running common pages from memory
3. Installed mod_ruid2 "...is a suexec module for apache which takes advantage of POSIX.1e capabilities to increase performance."
4. Corrected some database tables that were not performing properly, causing extra processing delays

So with all those great things added, it was discovered that there were some messy database tables when a "check tables" operation was performed. In trying to repair these tables, other data broke in a chain reaction during the normal course of the database doing its job. Ultimately, we had to restore our most recent version of our tables, and then running a different kind of repair that the Web Host keeps in its arsenal.

Once the database was cleaned up and fixed, the rest of the site came back to life, and blazingly fast!

My hope is that this performance gain will remain, and I'll work to include these features in the upcoming llresearch.org site, which will include the Bring4th forums, as well.

I can't thank you guys enough for your patience, I know it can be frustrating to have to deal with outages from time to time, but I'm hoping these recent changes will help eliminate the sluggishness and the "500 Internal Error" messages that some have been receiving.

Moving from 100% managed hosting to our own server has been quite an experience, as we have to work to resolve our own performance issues, security breaches, and anything else that can go wrong with the system. Thankfully, we have two good hosts who are able to assist us through such issues.

Now back to developing the other site! Take care...
Steve
Find all posts by this user
Like Post Quote this message in a reply
The following 9 users Like Bring4th_Steve's post:
Ankh, isis, Jade, kycahi, Matt1, native, Parsons, Sabou, sunnysideup


Messages In This Thread
RE: Anyone having issues accessing the forums - Melissa - 11-20-2013, 01:46 PM
RE: Anyone having issues accessing the forums - Melissa - 11-20-2013, 05:59 PM
RE: Anyone having issues accessing the forums - Melissa - 11-22-2013, 01:21 AM
RE: Anyone having issues accessing the forums - Melissa - 11-23-2013, 11:57 AM
RE: Anyone having issues accessing the forums - Melissa - 01-21-2014, 06:22 AM
RE: Anyone having issues accessing the forums - Melissa - 01-20-2014, 02:15 PM
RE: Anyone having issues accessing the forums - Unbound - 11-03-2014, 04:12 PM
RE: Anyone having issues accessing the forums - michael430 - 11-04-2014, 12:20 PM
RE: Anyone having issues accessing the forums - michael430 - 11-04-2014, 02:42 PM
RE: Anyone having issues accessing the forums - michael430 - 11-08-2014, 09:56 AM
RE: Anyone having issues accessing the forums - Bring4th_Steve - 11-14-2014, 03:04 AM



Users browsing this thread: 1 Guest(s)